[Japanese]

JVNDB-2020-000084

Apache Struts 2 vulnerable to remote code execution (S2-061)

Overview

Apache Struts 2 provided by The Apache Software Foundation contains a remote code execution vulnerability due to improper input validation (CWE-20).

Masato Anzai of Aeye Security Lab, inc. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

CVSS V3 Severity:
Base Metrics 8.1 (High) [IPA Score]
  • Attack Vector: Network
  • Attack Complexity: High
  • Privileges Required: None
  • User Interaction: None
  • Scope: Unchanged
  • Confidentiality Impact: High
  • Integrity Impact: High
  • Availability Impact: High
CVSS V2 Severity:
Base Metrics 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial
Affected Products


Apache Software Foundation
  • Apache Struts 2.0.0 to 2.5.25

Impact

A remote attacker may execute arbitrary code.
Solution

[Update the software]
Update the software to the latest version according to the information provided by the developer.

[Apply the workaround]
Do not use forced OGNL evaluation in the tag's attributes based on untrusted/unvalidated user input.
The developer reccomends the users to follow the recommendations from the Security Guide.
Vendor Information

Apache Software Foundation NEC Corporation
CWE (What is CWE?)

  1. Improper Input Validation(CWE-20) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2020-17530
References

  1. JVN : JVN#43969166
  2. JPCERT : Alert Regarding Vulnerability in Apache Struts 2 (S2-061)
Revision History

  • [2020/12/11]
      Web page was published
  • [2022/04/19]
      Vendor Information : Content was added
  • [2022/08/09]
      Vendor Information : Content was added