[Japanese]

JVNDB-2019-000059

apng-drawable vulnerable to integer overflow

Overview

apng-drawable provided by LINE Corporation contains an integer overflow vulnerability (CWE-190).

LINE Corporation reported this vulnerability to JPCERT/CC to notify users of its solution through JVN. JPCERT/CC and LINE Corporation coordinated under the Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

CVSS V3 Severity:
Base Metrics 5.3 (Medium) [IPA Score]
  • Attack Vector: Local
  • Attack Complexity: Low
  • Privileges Required: None
  • User Interaction: Required
  • Scope: Unchanged
  • Confidentiality Impact: Low
  • Integrity Impact: Low
  • Availability Impact: Low
CVSS V2 Severity:
Base Metrics 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial
Affected Products


LINE Corporation
  • apng-drawable 1.0.0 to 1.6.0

Impact

An attacker may cause a denial of service (DoS) condition or execute arbitrary code.
Solution

[Update the Software]
The developer released apng-drawable that contains a fix for this vulnerability.
Update the software to the below version according to the information provided by the developer.

* apng-drawable 1.7.0
Vendor Information

LINE Corporation
CWE (What is CWE?)

  1. Numeric Errors(CWE-189) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2019-6007
References

  1. JVN : JVN#39383894
  2. National Vulnerability Database (NVD) : CVE-2019-6007
Revision History

  • [2019/09/12]
      Web page was published
  • [2019/10/04]
      References : Content was added