BlueZ userland utilities vulnerable to buffer overflow


BlueZ provides a Bluetooth protocol stack for Linux kernel and userland utilities.
parse_line() function used in some userland utilities contains a buffer overflow vulnerability.

Hiroki MATSUKUMA of Cyber Defense Institute, Inc. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

CVSS V3 Severity:
Base Metrics 4.5 (Medium) [IPA Score]
  • Attack Vector: Local
  • Attack Complexity: High
  • Privileges Required: Low
  • User Interaction: None
  • Scope: Unchanged
  • Confidentiality Impact: Low
  • Integrity Impact: Low
  • Availability Impact: Low
CVSS V2 Severity:
Base Metrics 3.5 (Low) [IPA Score]
  • Access Vector: Local
  • Access Complexity: High
  • Authentication: Single Instance
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial
Affected Products

BlueZ Project
  • BlueZ 5.41 and earlier


An attacker who can access the product may execute arbitrary code.

[Update the Software]
Update to the latest version according to the information provided by the developer.
Vendor Information

BlueZ Project
CWE (What is CWE?)

  1. Buffer Errors(CWE-119) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2016-7837

  1. JVN : JVN#38755305
  2. National Vulnerability Database (NVD) : CVE-2016-7837
Revision History

  • [2016/12/22]
      Web page was published
      References : Content was added