【活用ガイド】

[English]

JVNDB-2017-000119

環境省が提供する報告書作成支援ツールのインストーラにおける任意のDLL読み込みの脆弱性

概要

環境省が提供する報告書作成支援ツールのインストーラには、DLL を読み込む際の検索パスに関する処理に不備があり、意図しない DLL を読み込んでしまう脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 橘総合研究所 英利 雅美 氏、Pink Flying Whale 黒翼猫 氏

CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

[参考] CVSS v3 による深刻度
基本値: 7.8 (重要) [IPA値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 低
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
影響を受けるシステム


環境省
  • 報告書作成支援ツール ver3.02(新規インストール用) (平成29年4月4日(火)〜平成29年5月18日(木)間にHP上に掲載されていた版)
  • 報告書作成支援ツール ver2.0以降(新規インストール用) (平成29年4月4日(火)より前にHP上に掲載されていた版)
  • 報告書作成支援ツール ver3.03(新規インストール用) (平成29年5月31日(水)〜平成29年6月12日(月)間にHP上に掲載されていた版)

想定される影響

インストーラを実行している権限で、任意のコードを実行される可能性があります。
対策

[最新のインストーラを使用する]
2017年6月12日以前にホームページに掲載されていた報告書作成支援ツール(Ver2.0〜3.03) をダウンロードしているユーザは、インストールせず速やかに削除してください。インストールする場合は、最新版の報告書作成支援ツール(Ver3.04) をダウンロードしなおしてから、インストールしてください。

開発者によると、当該インストーラを削除した後、念のため最新のパターンファイルを適用しているウィルス対策ソフト等でのウィルススキャンを推奨するとのことです。

本脆弱性の影響を受けるのはインストーラの起動時のみです。報告書作成支援ツールをインストール済みの既存ユーザは影響を受けません。

詳しくは、製品開発者が提供する情報をご確認ください。
ベンダ情報

環境省
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2017-2209
参考情報

  1. JVN : JVN#24087303
  2. JVN : JVNTA#91240916
更新履歴

[2017年06月05日]
  掲載
[2017年06月15日]
  影響を受けるシステム:内容を更新
  対策:内容を更新
[2017年08月02日]
  概要:内容を更新
  影響を受けるシステム:内容を更新
  対策:内容を更新