[Japanese]

JVNDB-2017-000119

Installer of Houkokusyo Sakusei Shien Tool provided by Ministry of the Environment may insecurely load Dynamic Link Libraries

Overview

Installer of Houkokusyo Sakusei Shien Tool provided by Ministry of the Environment contains an issue with the DLL search path, which may lead to insecurely loading Dynamic Link Libraries.

Eili Masami of Tachibana Lab. and BlackWingCat of Pink Flying Whale reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

CVSS V3 Severity:
Base Metrics: 7.8 (High) [IPA Score]
  • Access Vector: Local
  • Attack Complexity: Low
  • Privileges Required: Low
  • User Interaction: None
  • Scope: Unchanged
  • Confidentiality Impact: High
  • Integrity Impact: High
  • Availability Impact: High
Affected Products


Ministry of the Environment
  • Installer of Houkokusyo Sakusei Shien Tool ver3.03(For the first installation) (The version which was available on the website from 2017 May 31 to 2017 June 12)
  • Installer of Houkokusyo Sakusei Shien Tool ver3.02(For the first installation) (The version which was available on the website from 2017 April 4 to 2017 May 18)
  • Installer of Houkokusyo Sakusei Shien Tool ver2.0 and later(For the first installation) (The versions which were available on the website prior to 2017 April 4)

Impact

Arbitrary code may be executed with the privileges of the running application.
Solution

[Use the latest installer]
The user who downloaded Houkokusyo Sakusei Shien Tool (Ver2.0 - 3.03) before 2017 June 12 should delete it immediately. When installing Houkokusyo Sakusei Shien Tool, be sure to download Houkokusyo Sakusei Shien Tool (Ver3.04) from the website and use the latest installer.

According to the developer, it is recommended for the users to execute virus scan software with the latest pattern files applied.

Note that this vulnerability affects the installer only, thus users who have already installed Houkokusyo Sakusei Shien Tool do not need to re-install the newer version (Ver3.04)

For more information, refer to the information provided by the developer.
Vendor Information

Ministry of the Environment
CWE (What is CWE?)

  1. No Mapping(CWE-Other) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2017-2209
References

  1. JVN : JVN#24087303
  2. JVN : JVNTA#91240916
Revision History

[2017/06/05]
  Web page was published
[2017/06/15]
  Affected Products : Product was added 
  Solution was modified
[2017/08/02]
  Overview was modified
  Affected Products : Content was modified
  Solution was modified