【活用ガイド】

[English]

JVNDB-2017-000018

脆弱性体験学習ツール AppGoat において任意のコードが実行可能な脆弱性

概要

独立行政法人情報処理推進機構 (IPA) が提供する AppGoat は、脆弱性体験学習用ツールです。「脆弱性体験学習ツール AppGoat ウェブアプリケーション用学習ツール」には、任意のコードが実行可能な脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 馬場 将次 氏

CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

[参考] CVSS v3 による深刻度
基本値: 6.3 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 低
  • 完全性への影響(I): 低
  • 可用性への影響(A): 低
影響を受けるシステム


独立行政法人情報処理推進機構 (IPA)
  • 脆弱性体験学習ツール AppGoat ウェブアプリケーション用学習ツール V3.0.0 およびそれ以前

想定される影響

細工されたウェブページにアクセスすることで、任意のコードを実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

独立行政法人情報処理推進機構 (IPA)
CWEによる脆弱性タイプ一覧  CWEとは?

  1. コード・インジェクション(CWE-94) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2017-2099
参考情報

  1. JVN : JVN#71666779
  2. National Vulnerability Database (NVD) : CVE-2017-2099
更新履歴

[2017年02月09日]
  掲載
[2017年06月01日]
  参考情報:National Vulnerability Database (NVD) (CVE-2017-2099) を追加