【活用ガイド】

[English]

JVNDB-2015-000088

Ruby on Rails 用ライブラリ Paperclip におけるクロスサイトスクリプティングの脆弱性

概要

thoughtbot が提供する Paperclip は、Ruby on Rails でファイルをアップロードするためのライブラリです。Paperclip には、格納型のクロスサイトスクリプティング (CWE-79) の脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 株式会社ディー・エヌ・エー 森 槙悟 氏

CVSS による深刻度 (CVSS とは?)

基本値: 4.3 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


thoughtbot
  • Paperclip 4.2.1 およびそれ以前

想定される影響

ユーザのウェブブラウザ上で任意のスクリプトを実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

thoughtbot
CWEによる脆弱性タイプ一覧  CWEとは?

  1. クロスサイトスクリプティング(CWE-79) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2015-2963
参考情報

  1. JVN : JVN#83881261
  2. National Vulnerability Database (NVD) : CVE-2015-2963
更新履歴

[2015年06月18日]
  掲載
[2015年07月14日]
  参考情報:National Vulnerability Database (NVD) (CVE-2015-2963) を追加