[Japanese]

JVNDB-2015-000088

Ruby on Rails library Paperclip vulnerable to cross-site scripting

Overview

Paperclip provided by thoughtbot is a library to upload files in Ruby on Rails. Paperclip contains a persistent cross-site scripting vulnerability (CWE-79).

MORI Shingo of DeNA Co., Ltd. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 4.3 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: None
  • Integrity Impact: Partial
  • Availability Impact: None

Affected Products


thoughtbot, inc.
  • Paperclip 4.2.1 and earlier

Impact

An arbitrary script may be executed on the user's web browser.
Solution

[Update the Software]
Update to the latest version according to the information provided by the developer.
Vendor Information

thoughtbot, inc.
CWE (What is CWE?)

  1. Cross-site Scripting(CWE-79) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2015-2963
References

  1. JVN : JVN#83881261
  2. National Vulnerability Database (NVD) : CVE-2015-2963
Revision History

[2015/06/18]
 Web page was published
[2015/07/14]
  References : Content was added