【活用ガイド】

[English]

JVNDB-2010-000026

Explzh におけるバッファオーバーフローの脆弱性

概要

Explzh には、バッファオーバーフローの脆弱性が存在します。

Explzh は、複数の圧縮ファイル形式に対応した圧縮・展開を主な機能とするソフトウェアです。Explzh には、LHA 書庫ファイルのヘッダ処理にバッファオーバーフローの脆弱性が存在します。

Explzh に含まれている Arcext.dll のバージョンが 2.16.1 およびそれ以前である場合、本脆弱性の影響を受けます。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC がベンダとの調整を行いました。
報告者:高野 健寿 氏

CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


pon software
  • Explzh Ver.5.62 およびそれ以前

想定される影響

細工された LHA 書庫ファイルを処理した場合、任意のコードを実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに最新版へアップデートしてください。
ベンダ情報

pon software
CWEによる脆弱性タイプ一覧  CWEとは?

  1. バッファエラー(CWE-119) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2010-2434
参考情報

  1. JVN : JVN#34729123
  2. National Vulnerability Database (NVD) : CVE-2010-2434
  3. Secunia Advisory : SA40324
  4. SecurityFocus : 41025
  5. ISS X-Force Database : 59624
  6. OPEN SOURCE VULNERABILITY DATABASE (OSVDB) : 65666
更新履歴

[2010年06月22日]
  掲載