[Japanese]

JVNDB-2010-000026

Explzh buffer overflow vulnerability

Overview

Explzh contains a buffer overflow vulnerability.

Explzh, a file compression/decompression software supporting multiple compression file formats, contains a buffer overflow vulnerability when processing a LHA file header.

Note that versions of Explzh that contain "Arcext.dll" version 2.16.1 and earlier are vulnerable.

Kenju Takano reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

Base Metrics: 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial

Affected Products


pon software
  • Explzh Ver.5.62 and earlier

Impact

When processing a specially crafted LHA file, a remote attacker may be able to execute arbitrary code.
Solution

[Update the Software]
Update to the latest version according to the information provided by the developer.
Vendor Information

pon software
CWE (What is CWE?)

  1. Buffer Errors(CWE-119) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2010-2434
References

  1. JVN : JVN#34729123
  2. National Vulnerability Database (NVD) : CVE-2010-2434
  3. Secunia Advisory : SA40324
  4. SecurityFocus : 41025
  5. ISS X-Force Database : 59624
  6. OPEN SOURCE VULNERABILITY DATABASE (OSVDB) : 65666
Revision History

[2010/6/22]
  Web page published