【活用ガイド】

JVNDB-2009-001443

phpMyAdmin の setup.php における任意の PHP コードを挿入される脆弱性

概要

phpMyAdmin の setup.php には、任意の PHP コードを挿入される脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 7.5 (危険) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


The phpMyAdmin Project
  • phpMyAdmin 2.11.x - 2.11.9.5 未満
  • phpMyAdmin 3.x - 3.1.3.1 未満

想定される影響

リモートの攻撃者により、 save アクションを介して、設定ファイルの中に任意の PHP コードを挿入される可能性があります。
対策

ベンダ情報および参考情報を参照して適切な対策を実施してください。
ベンダ情報

The phpMyAdmin Project
CWEによる脆弱性タイプ一覧  CWEとは?

  1. コード・インジェクション(CWE-94) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2009-1151
参考情報

  1. National Vulnerability Database (NVD) : CVE-2009-1151
更新履歴

[2009年06月30日]
  掲載