【活用ガイド】

[English]

JVNDB-2023-003956

オムロン製 CX-Designer における XML 外部実体参照(XXE)の脆弱性

概要

オムロン株式会社が提供する CX-Designer には、XML 外部実体参照(XXE)の脆弱性(CWE-611)が存在します。

この脆弱性情報は、下記の方が JPCERT/CC に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: Michael Heinzl 氏

CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 5.5 (警告) [その他]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし
影響を受けるシステム


オムロン株式会社
  • CX-Designer Ver.3.740 およびそれ以前(CX-One CXONE-AL□□D-V4 に同梱)

バージョンの確認方法は、開発者が提供するマニュアル「CX-Designer Version3.□ ユーザーズマニュアル(SBSA-532)」を参照してください。
想定される影響

攻撃者によって細工されたプロジェクトファイルをユーザーが開くことで、CX-Designer がインストールされたファイルシステムにある機微な情報が漏えいする可能性があります。

対策

[アップデートする]
開発者が提供する情報をもとに、最新版にアップデートしてください。
開発者は、本脆弱性に対応した次のバージョンをリリースしています。

 * CX-Designer Ver.3.750 およびそれ以降(CX-One CXONE-AL□□D-V4 に同梱)
ベンダ情報

オムロン株式会社
CWEによる脆弱性タイプ一覧  CWEとは?

  1. XML 外部エンティティ参照の不適切な制限(CWE-611) [その他]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2023-43624
参考情報

  1. JVN : JVNVU#98683567
更新履歴

  • [2023年10月24日]
      掲載