【活用ガイド】

JVNDB-2021-007581

postgresql におけるバッファエラーの脆弱性

概要

postgresql には、バッファエラーの脆弱性、および整数オーバーフローの脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 8.8 (重要) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 低
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
CVSS v2 による深刻度
基本値: 6.5 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的
影響を受けるシステム


PostgreSQL.org
  • PostgreSQL 13.3 未満
  • PostgreSQL 12.7 未満
  • PostgreSQL 11.12 未満
  • PostgreSQL 10.17 未満
  • PostgreSQL 9.6.22 未満
レッドハット
  • JBoss Enterprise Application Platform
  • Red Hat Software Collections
  • Red Hat Enterprise Linux

本脆弱性の影響を受ける製品の詳細については、ベンダ情報および参考情報をご確認ください。
想定される影響

情報を取得される、情報を改ざんされる、およびサービス運用妨害 (DoS) 状態にされる可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

PostgreSQL.org レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

  1. バッファエラー(CWE-119) [その他]
  2. 整数オーバーフローまたはラップアラウンド(CWE-190) [その他]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2021-32027
参考情報

  1. JVN : JVNVU#93772356
  2. National Vulnerability Database (NVD) : CVE-2021-32027
  3. ICS-CERT ADVISORY : ICSA-22-111-03
更新履歴

  • [2022年02月17日]
      掲載
  • [2022年04月26日]
      参考情報:JVN (JVNVU#93772356) を追加
      参考情報:ICS-CERT ADVISORY (ICSA-22-111-03) を追加