【活用ガイド】

JVNDB-2021-002996

Netty における誤った領域へのリソースの漏えいに関する脆弱性

概要

Netty には、誤った領域へのリソースの漏えいに関する脆弱性が存在します。

CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 5.5 (警告) [NVD値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 低
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし
CVSS v2 による深刻度
基本値: 1.9 (注意) [NVD値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし
影響を受けるシステム


Debian
  • Debian GNU/Linux
Quarkus
  • Quarkus
The Netty project
  • Netty 4.1.59 未満
オラクル
  • Oracle NoSQL Database
日立
  • Hitachi Ops Center Common Services (海外販売のみ)

本脆弱性の影響を受ける製品の詳細については、ベンダ情報および参考情報をご確認ください。
想定される影響

情報を取得される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Debian Quarkus The Netty project オラクル 日立
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 誤った領域へのリソースの漏えい(CWE-668) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2021-21290
参考情報

  1. National Vulnerability Database (NVD) : CVE-2021-21290
  2. 関連文書 : [GitHub] [kafka] dongjinleekr commented on pull request #10235: KAFKA-12389: Upgrade of netty-codec due to CVE-2021-21290
  3. 関連文書 : [jira] [Created] (KAFKA-12389) Upgrade of netty-codec due to CVE-2021-21290 <dev.kafka.apache.org>
  4. 関連文書 : [jira] [Created] (KAFKA-12389) Upgrade of netty-codec due to CVE-2021-21290 <jira.kafka.apache.org>
更新履歴

  • [2021年10月14日]
      掲載