【活用ガイド】

JVNDB-2021-001012

複数の Delta Electronics 製品に脆弱性

概要

Delta Electronics 社が提供する複数の製品には、次の脆弱性が存在します。

 * 解放済みメモリの使用 (Use-after-free) (CWE-416) - CVE-2020-27280
 * 信頼できないポインタ参照 (CWE-822) - CVE-2020-27288
 * 境界外書き込み (CWE-787) - CVE-2020-27284
CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 7.8 (重要) [IPA値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
※上記は、CVE-2020-27280の評価になります。


CVSS v3 による深刻度
基本値: 7.8 (重要) [IPA値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
※上記は、CVE-2020-27288の評価になります。


CVSS v3 による深刻度
基本値: 7.8 (重要) [IPA値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
※上記は、CVE-2020-27284の評価になります。
影響を受けるシステム


Delta Electronics
  • TPEditor v1.98 およびそれ以前 - CVE-2020-27284、CVE-2020-27288
  • ISPSoft v3.12 およびそれ以前 - CVE-2020-27280

想定される影響

いずれの脆弱性も、細工されたプロジェクトファイルを処理することによりアプリケーションの権限で、任意のコードが実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、以下のバージョンにアップデートしてください。

CVE-2020-27280

 * ISPSoft v3.12.01
  * Deltaカスタマーサービスに連絡することで対策済みバージョンを入手することができます。


CVE-2020-27284、CVE-2020-27288

 * TPEditor v1.98.03 またはそれ以降
ベンダ情報

Delta Electronics
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 解放済みメモリの使用(CWE-416) [IPA評価]
  2. 境界外書き込み(CWE-787) [IPA評価]
  3. 信頼性のないポインタデリファレンス(CWE-822) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2020-27280
  2. CVE-2020-27284
  3. CVE-2020-27288
参考情報

  1. JVN : JVNVU#95339074
  2. ICS-CERT ADVISORY : ICSA-21-021-01
  3. ICS-CERT ADVISORY : ICSA-21-021-02
更新履歴

  • [2021年01月25日]
      掲載