【活用ガイド】

[English]

JVNDB-2021-000035

EC-CUBE におけるクロスサイトスクリプティングの脆弱性

概要

株式会社イーシーキューブが提供する EC-CUBE には、クロスサイトスクリプティング (CWE-79) の脆弱性が存在します。
EC-CUBE の管理画面において、特定の操作を実行する際に任意のスクリプトが実行されます。

2021年5月10日現在、本脆弱性を悪用した攻撃がすでに確認されています。

この脆弱性情報は、製品利用者への周知を目的に開発者が JPCERT/CC に報告し、JPCERT/CC が開発者との調整を行いました。
CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 7.1 (重要) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更あり
  • 機密性への影響(C): 低
  • 完全性への影響(I): 低
  • 可用性への影響(A): 低
CVSS v2 による深刻度
基本値: 6.8 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的
影響を受けるシステム


株式会社イーシーキューブ
  • EC-CUBE 4.0.0 から 4.0.5 まで

想定される影響

当該製品で作成されたECサイトにおいて、攻撃者が特定の入力欄にスクリプトを入力することにより、ECサイトの管理者のブラウザ上で任意のスクリプトが実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとにアップデートしてください。開発者から本脆弱性に対応した次のバージョンが提供されています。
・4.0.5-p1

[パッチを適用する]
開発者が提供する情報をもとに差分ファイル (Hotfix パッチ) を適用してください。
ベンダ情報

株式会社イーシーキューブ
CWEによる脆弱性タイプ一覧  CWEとは?

  1. クロスサイトスクリプティング(CWE-79) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2021-20717
参考情報

  1. JVN : JVN#97554111
  2. IPA 重要なセキュリティ情報 : 「EC-CUBE」におけるクロスサイトスクリプティングの脆弱性について(JVN#97554111)
  3. JPCERT 注意喚起 : EC-CUBEのクロスサイトスクリプティングの脆弱性(CVE-2021-20717)に関する注意喚起
更新履歴

  • [2021年05月10日]
      掲載