【活用ガイド】

[English]

JVNDB-2021-000031

スマートフォンアプリ「ぐるなび」におけるアクセス制限不備の脆弱性

概要

株式会社ぐるなびが提供するスマートフォンアプリ「ぐるなび」には、Custom URL Scheme を使用してリクエストされた URL にアクセスする機能が実装されています。この機能には、任意のアプリからリクエストを受け取りアクセスを実行してしまう、アクセス制限不備の脆弱性 (CWE-284) が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者:佐藤竜 氏

CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 3.3 (注意) [IPA値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): なし
  • 完全性への影響(I): 低
  • 可用性への影響(A): なし
CVSS v2 による深刻度
基本値: 4.3 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし
影響を受けるシステム


株式会社ぐるなび
  • ぐるなび Android アプリ ver.10.0.14 およびそれ以前
  • ぐるなび iOS アプリ ver.11.2.3 およびそれ以前

【2021/05/24 追記】
本件を2021年4月14日に公表した時点では、影響を受ける製品は「Android アプリ「ぐるなび」 ver.10.0.10 およびそれ以前」、「iOS アプリ「ぐるなび」 ver.11.1.2 およびそれ以前」と記載していましたが、修正が不十分であったことが確認されたためバージョン情報を更新しました。
想定される影響

遠隔の第三者によって、当該製品を経由し任意のウェブサイトにアクセスさせられる可能性があります。結果として、フィッシング等の被害にあう可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

株式会社ぐるなび
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 認可・権限・アクセス制御(CWE-264) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2021-20693
参考情報

  1. JVN : JVN#54025691
更新履歴

  • [2021年04月14日]
      掲載
  • [2021年05月24日]
     影響を受けるシステム:内容を更新