【活用ガイド】

[English]

JVNDB-2021-000019

GROWI における複数のクロスサイトスクリプティングの脆弱性

概要

株式会社WESEEK が提供する GROWI には、次に挙げる複数のクロスサイトスクリプティングの脆弱性が存在します。
・URL のクエリパラメータの検証不備による反射型クロスサイトスクリプティング (CWE-79) - CVE-2021-20672
・管理者画面における格納型クロスサイトスクリプティング (CWE-79) - CVE-2021-20673

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 株式会社スリーシェイク 宮口直也 氏
CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 4.8 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 高
  • 利用者の関与: 要
  • 影響の想定範囲: 変更あり
  • 機密性への影響(C): 低
  • 完全性への影響(I): 低
  • 可用性への影響(A): なし
CVSS v2 による深刻度
基本値: 3.5 (注意) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし
※上記は、CVE-2021-20673の評価になります。


CVSS v3 による深刻度
基本値: 6.1 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更あり
  • 機密性への影響(C): 低
  • 完全性への影響(I): 低
  • 可用性への影響(A): なし
CVSS v2 による深刻度
基本値: 2.6 (注意) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし
※上記は、CVE-2021-20672の評価になります。
影響を受けるシステム


株式会社WESEEK
  • GROWI v4.2.0 から v4.2.7 までのバージョン (v4.2系)

開発者によると、本脆弱性の影響を受けるのは v4.2系のみとのことです。
想定される影響

当該製品にログインした状態のユーザのウェブブラウザ上で、任意のスクリプトを実行される可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版にアップデートしてください。
ベンダ情報

株式会社WESEEK
CWEによる脆弱性タイプ一覧  CWEとは?

  1. クロスサイトスクリプティング(CWE-79) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2021-20672
  2. CVE-2021-20673
参考情報

  1. JVN : JVN#86438134
更新履歴

  • [2021年03月10日]
      掲載