【活用ガイド】

[English]

JVNDB-2020-000074

Hibernate ORM における SQL インジェクションの脆弱性

概要

Hibernate ORM は Java 向けの ORM フレームワークです。Hibernate ORM では、デバッグに役立つよう、内部で生成する SQL 文にコメントをつけることができます。(hibernate.use_sql_comments を true に設定する。初期設定では false。)
hibernate.use_sql_comments を true に設定した場合の入力処理には不備があり、SQL インジェクションの脆弱性 (CWE-89) が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: (株)NTTデータ 技術革新統括本部 システム技術本部 デジタル技術部 インテグレーション技術担当 TERASOLUNA Framework 開発チーム

CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 7.4 (重要) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): なし
CVSS v2 による深刻度
基本値: 4.0 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし
影響を受けるシステム


Hibernate
  • Hibernate ORM 5.4.24 より前のバージョン
  • Hibernate ORM 5.3.20 より前のバージョン

想定される影響

hibernate.use_sql_comments を true に設定している場合、細工した入力を処理することで SQL インジェクション攻撃を受ける可能性があります。
対策

[アップデートする]
開発者が提供する情報を参考に、Hibernate ORM を更新してください。

[ワークアラウンドを実施する]
hibernamte.use_sql_comments を false に設定してください。
ベンダ情報

Hibernate レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

  1. SQLインジェクション(CWE-89) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2020-25638
参考情報

  1. JVN : JVN#90729322
更新履歴

  • [2020年11月19日]
      掲載