【活用ガイド】

JVNDB-2019-012541

AngularJS における入力確認に関する脆弱性

概要

AngularJS には、入力確認に関する脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 7.5 (重要) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): なし
  • 完全性への影響(I): 高
  • 可用性への影響(A): なし
CVSS v2 による深刻度
基本値: 5.0 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし
影響を受けるシステム


Angular
  • AngularJS 1.7.9 未満

想定される影響

情報を改ざんされる可能性があります。
対策

ベンダ情報および参考情報を参照して適切な対策を実施してください。
ベンダ情報

Angular
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 不適切な入力確認(CWE-20) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2019-10768
参考情報

  1. JVN : JVNVU#94872807
  2. National Vulnerability Database (NVD) : CVE-2019-10768
  3. ICS-CERT ADVISORY : ICSA-20-133-02
  4. 関連文書 : SNYK-JS-ANGULAR-534884  (Affecting angular package, versions <1.7.9)
更新履歴

  • [2019年12月04日]
      掲載
  • [2020年05月13日]
      参考情報:ICS-CERT ADVISORY (ICSA-20-133-02) を追加
  • [2020年06月11日]
      参考情報:JVN (JVNVU#94872807) を追加