【活用ガイド】

[English]

JVNDB-2019-000015

iOS アプリ「iChain保険ウォレット」におけるディレクトリトラバーサルの脆弱性

概要

iChain株式会社が提供する iOS アプリ「iChain保険ウォレット」には、当該製品で使用されている古いバージョンの cordova-plugin-ionic-webview に存在する脆弱性 (CVE-2018-16202) が原因となる、ディレクトリトラバーサル (CWE-22) の脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 三井物産セキュアディレクション株式会社 望月岳 氏

CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 4.7 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更あり
  • 機密性への影響(C): 低
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし
CVSS v2 による深刻度
基本値: 4.3 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし
影響を受けるシステム


iChain株式会社
  • iChain保険ウォレット iOS アプリ バージョン 1.3.0 およびそれ以前

想定される影響

遠隔の第三者によって、iOS デバイス内のファイルやアプリケーションに関連するファイルが取得され、ファイル内の情報 (アプリケーションの設定やコード、アプリケーションが保存した情報等) が漏えいする可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

iChain株式会社
CWEによる脆弱性タイプ一覧  CWEとは?

  1. パス・トラバーサル(CWE-22) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2019-5923
参考情報

  1. JVN : JVN#11622218
  2. JVN : JVN#69812763
更新履歴

  • [2019年03月12日]
       掲載