【活用ガイド】

[English]

JVNDB-2018-000007

「MagicalFinder (マジカルファインダー)」に対応したアイ・オー・データ製複数の機器における OS コマンドインジェクションの脆弱性

概要

株式会社アイ・オー・データ機器が提供する「MagicalFinder (マジカルファインダー)」は、アイ・オー・データ製ネットワーク機器に対応した IP アドレス設定ツールです。「MagicalFinder (マジカルファインダー)」に対応した複数の機器には、OS コマンドインジェクション (CWE-78) の脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 三井物産セキュアディレクション株式会社 塚本 泰三 氏

CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 6.8 (警告) [IPA値]
  • 攻撃元区分: 隣接
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 高
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
CVSS v2 による深刻度
基本値: 5.2 (警告) [IPA値]
  • 攻撃元区分: 隣接
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的
影響を受けるシステム


株式会社アイ・オー・データ機器
  • BX-VP1 ファームウェアバーション 2.01 およびそれ以前
  • GV-NTX1 ファームウェアバーション 1.02.00 およびそれ以前
  • GV-NTX2 ファームウェアバーション 1.02.00 およびそれ以前
  • HDL-A シリーズ ファームウェアバーション 1.26 およびそれ以前
  • HDL-AH シリーズ ファームウェアバーション 1.26 およびそれ以前
  • HDL-GT シリーズ ファームウェアバーション 1.37 およびそれ以前
  • HDL-GTR シリーズ ファームウェアバーション 1.37 およびそれ以前
  • HDL-T シリーズ ファームウェアバーション 1.12 およびそれ以前
  • HDL-XR シリーズ ファームウェアバーション 2.01 およびそれ以前
  • HDL-XR2U シリーズ ファームウェアバーション 2.01 およびそれ以前
  • HDL-XR2UW シリーズ ファームウェアバーション 2.01 およびそれ以前
  • HDL-XRW シリーズ ファームウェアバーション 2.01 およびそれ以前
  • HDL-XV シリーズ ファームウェアバーション 1.50 およびそれ以前
  • HDL-XVW シリーズ ファームウェアバーション 1.50 およびそれ以前
  • HDL2-A シリーズ ファームウェアバーション 1.26 およびそれ以前
  • HDL2-AH シリーズ ファームウェアバーション 1.26 およびそれ以前
  • HFAS1 シリーズ ファームウェアバーション 1.40 およびそれ以前
  • HLS-C シリーズ ファームウェアバーション 1.12 およびそれ以前
  • HVL-ATAシリーズ ファームウェアバーション 2.04 およびそれ以前
  • HVL-ATシリーズ ファームウェアバーション 2.04 およびそれ以前
  • HVL-Aシリーズ ファームウェアバーション 2.04 およびそれ以前
  • HVL-S シリーズ ファームウェアバーション 1.00 およびそれ以前
  • WHG-AC1750/A ファームウェアバーション 3.00 およびそれ以前
  • WHG-AC1750/AL ファームウェアバーション 1.07 およびそれ以前
  • WHG-NAPG/A ファームウェアバーション 1.08 およびそれ以前
  • WHG-NAPG/AL ファームウェアバーション 1.05 およびそれ以前
  • WN-AC1167DGR ファームウェアバーション 1.02 およびそれ以前
  • WN-AC1300EX ファームウェアバーション 1.02 およびそれ以前
  • WN-AC1600DGR ファームウェアバーション 2.06 およびそれ以前
  • WN-AC583RK ファームウェアバーション 1.06 およびそれ以前
  • WN-AC583TRK ファームウェアバーション 1.05 およびそれ以前
  • WN-AG300DGR ファームウェアバーション 1.05 およびそれ以前
  • WN-AG750DGR ファームウェアバーション 1.08 およびそれ以前
  • WN-AX1167GR ファームウェアバーション 3.11 およびそれ以前
  • WN-G300EX ファームウェアバーション 1.01 およびそれ以前
  • WN-G300R ファームウェアバーション 1.14 およびそれ以前
  • WN-G300R3 ファームウェアバーション 1.04 およびそれ以前
  • WN-G300SR ファームウェアバーション 1.00 およびそれ以前
  • WN-GX300GR ファームウェアバーション 2.00 およびそれ以前
  • WNPR1167F ファームウェアバーション 1.00 およびそれ以前
  • WNPR1167G ファームウェアバーション 1.00 およびそれ以前
  • WNPR1750G ファームウェアバーション 1.01 およびそれ以前
  • WNPR2600G ファームウェアバーション 1.01 およびそれ以前

想定される影響

当該製品にログイン可能な第三者によって、任意の OS コマンドを実行される可能性があります。
対策

[ファームウエアアップデートを適用する]
開発者が提供する情報をもとに、各製品に対応した適切なファームウエアアップデートを適用してください。
ベンダ情報

株式会社アイ・オー・データ機器
CWEによる脆弱性タイプ一覧  CWEとは?

  1. OSコマンドインジェクション(CWE-78) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2018-0512
参考情報

  1. JVN : JVN#36048131
更新履歴

  • [2018年02月06日]
      掲載