【活用ガイド】

JVNDB-2017-002786

Linux Kernel の net/packet/af_packet.c の packet_set_ring 関数におけるサービス運用妨害 (DoS) の脆弱性

概要

Linux Kernel の net/packet/af_packet.c の packet_set_ring 関数は、特定の block-size データを適切に検証しないため、サービス運用妨害 (オーバーフロー) 状態にされる脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

CVSS v3 による深刻度
基本値: 7.8 (重要) [NVD値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 低
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
CVSS v2 による深刻度
基本値: 7.2 (危険) [NVD値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 全面的
  • 完全性への影響(I): 全面的
  • 可用性への影響(A): 全面的
影響を受けるシステム


Linux
  • Linux Kernel 4.10.6 まで

想定される影響

ローカルユーザにより、巧妙に細工されたシステムコールを介して、サービス運用妨害 (オーバーフロー) 状態にされる、不特定の影響を受ける可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

kernel.org Linux
CWEによる脆弱性タイプ一覧  CWEとは?

  1. バッファエラー(CWE-119) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2017-7308
参考情報

  1. National Vulnerability Database (NVD) : CVE-2017-7308
更新履歴

  • [2017年04月28日]
      掲載