【活用ガイド】

JVNDB-2016-001692

OpenSSL の crypto/dh/dh_check.c の DH_check_pub_key 関数におけるプライベート DH 指数を取得される脆弱性

概要

OpenSSL の crypto/dh/dh_check.c の DH_check_pub_key 関数は、素数がディフィー・ヘルマン (DH) 鍵交換に適切であることを確認しないため、プライベート DH 指数を取得される脆弱性が存在します。

なお、JVNVU#95668716 では、CWE-325 として公開されています。

CWE-325: Missing Required Cryptographic Step
https://cwe.mitre.org/data/definitions/325.html
CVSS による深刻度 (CVSS とは?)

CVSS v2 による深刻度
基本値: 2.6 (注意) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし
影響を受けるシステム


OpenSSL Project
  • OpenSSL 1.0.2f 未満の 1.0.2
ヒューレット・パッカード・エンタープライズ
  • HPE Universal CMDB Foundation Software 10.0
  • HPE Universal CMDB Foundation Software 10.01
  • HPE Universal CMDB Foundation Software 10.10
  • HPE Universal CMDB Foundation Software 10.11
  • HPE Universal CMDB Foundation Software 10.20
  • HPE Universal CMDB Foundation Software 10.21 UD Agent
日本電気
  • CapsSuite V3.0 から V4.0 のマネージャコンポーネント
  • ESMPRO/ServerAgent Ver4.4.22-1以降 (Linux)
  • ESMPRO/ServerAgentService 全バージョン (Linux)
  • SecureWare/PKIアプリケーション開発キット Ver3.0
  • SecureWare/PKIアプリケーション開発キット Ver3.01
  • SecureWare/PKIアプリケーション開発キット Ver3.02
  • SecureWare/PKIアプリケーション開発キット Ver3.1
  • WebSAM Application Navigator Agent Ver3.3 から Ver4.1
  • WebSAM Application Navigator Manager Ver3.2.2 から Ver4.1
  • WebSAM MCOperations Ver3.6.2 から Ver4.2
  • WebSAM SystemManager Ver5.5.2 から Ver6.2.1
  • Express5800 /SG シリーズ InterSecVM/SG v1.2、v3.0、v3.1、v4.0
  • Express5800 /SG シリーズ SG3600LM/LG/LJ v6.1、v6.2、v7.0、v7.1、v8.0、v8.2
  • Express5800 /SG シリーズ UNIVERGE SG3000LG/LJ

本脆弱性の影響を受ける日本電気製品の詳細については、ベンダ情報 NV16-007 をご確認ください。
想定される影響

第三者により、不適切な数を選択したピアとのハンドシェイクを複数回実行されることで、プライベート DH 指数を取得される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Google OpenBSD OpenSSL Project オラクル ターボリナックス ヒューレット・パッカード・エンタープライズ 日本電気
  • NEC製品セキュリティ情報 : NV16-007
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 情報漏えい(CWE-200) [NVD評価]
  2. その他(CWE-Other) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-0701
参考情報

  1. JVN : JVNVU#95668716
  2. National Vulnerability Database (NVD) : CVE-2016-0701
  3. US-CERT Vulnerability Note : VU#257823
  4. 関連文書 : OpenSSL Key Recovery Attack on DH small subgroups (CVE-2016-0701)
更新履歴

  • [2016年03月15日]
      掲載
    [2016年06月23日]
      影響を受けるシステム:ベンダ情報の追加に伴い内容を更新
      ベンダ情報:ヒューレット・パッカード・エンタープライズ (HPSBGN03621) を追加
      ベンダ情報:日本電気 (NV16-007) を追加
    [2016年08月02日]
      影響を受けるシステム:ベンダ情報の更新に伴い内容を更新
    [2016年08月25日]
      影響を受けるシステム:ベンダ情報の更新に伴い内容を更新
    [2016年11月22日]
      ベンダ情報:オラクル (Oracle Critical Patch Update Advisory - July 2016) を追加