【活用ガイド】

JVNDB-2006-000127

initscripts における root 権限を取得される脆弱性

概要

initscripts には、/sbin/service コマンドを実行する際に複数の環境変数の処理が不適切である脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

CVSS v2 による深刻度
基本値: 7.2 (危険) [NVD値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 全面的
  • 完全性への影響(I): 全面的
  • 可用性への影響(A): 全面的
影響を受けるシステム


ミラクル・リナックス
  • Asianux Server 4.0 
  • Asianux Server 4.0 (x86-64) 
レッドハット
  • Red Hat Enterprise Linux 3 (as) 
  • Red Hat Enterprise Linux 4 (as) 
  • Red Hat Enterprise Linux 3 (es) 
  • Red Hat Enterprise Linux 4 (es) 
  • Red Hat Enterprise Linux 3 (ws) 
  • Red Hat Enterprise Linux 4 (ws) 

想定される影響

一般ユーザが sudo を介して /sbin/service コマンドを root 権限で実行可能である場合、 root 権限を取得される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

ミラクル・リナックス
  • MIRACLE LINUX アップデート情報 : initscripts
レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2005-3629
参考情報

  1. National Vulnerability Database (NVD) : CVE-2005-3629
  2. SecurityFocus : 17038
更新履歴

  • [2007年04月01日]
      掲載