[Japanese]

JVNDB-2021-000025

WordPress plugin "Paid Memberships Pro" vulnerable to SQL injection

Overview

WordPress Plugin "Paid Memberships Pro" contains an SQL injection vulnerability (CWE-89).

Gen Sato of Mitsui Bussan Secure Directions, Inc. reported this vulnerability to the developer and coordinated on his own.
After coordination was completed, this case was reported to JPCERT/CC, and JPCERT/CC coordinated with the developer for the publication.
CVSS Severity (What is CVSS?)

CVSS V3 Severity:
Base Metrics 6.3 (Medium) [IPA Score]
  • Attack Vector: Network
  • Attack Complexity: Low
  • Privileges Required: Low
  • User Interaction: None
  • Scope: Unchanged
  • Confidentiality Impact: Low
  • Integrity Impact: Low
  • Availability Impact: Low
CVSS V2 Severity:
Base Metrics 6.5 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Low
  • Authentication: Single Instance
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial
Affected Products


Stranger Studios
  • Paid Memberships Pro versions prior to 2.5.6

Impact

An attacker who can access Paid Membership Pro may obtain and/or alter the information stored in the database.
Solution

[Update the plugin]
Update the plugin according to the information provided by the developer.
Vendor Information

Stranger Studios
CWE (What is CWE?)

  1. SQL Injection(CWE-89) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2021-20678
References

  1. JVN : JVN#08191557
Revision History

  • [2021/03/17]
      Web page was published