[Japanese]

JVNDB-2021-000007

OS command injection vulnerability in multiple Infoscience Corporation log management tools

Overview

Infoscience Corporation's multiple log management tools provide an FTP upload function as one of the log collection methods, and is able to set to allow the adminitrators to accept FTP uploads.
In a situation where the FTP upload function is enabled and there is a flaw of input value handling in the log processing, a remote attacker who can upload a crafted log via FTP may execute an arbitrary OS command on the server where the products are running (CWE-78).

Taizoh Tsukamoto of Mitsui Bussan Secure Directions, Inc. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

CVSS V3 Severity:
Base Metrics 7.5 (High) [IPA Score]
  • Attack Vector: Network
  • Attack Complexity: High
  • Privileges Required: Low
  • User Interaction: None
  • Scope: Unchanged
  • Confidentiality Impact: High
  • Integrity Impact: High
  • Availability Impact: High
CVSS V2 Severity:
Base Metrics 7.1 (High) [IPA Score]
  • Access Vector: Network
  • Access Complexity: High
  • Authentication: Single Instance
  • Confidentiality Impact: Complete
  • Integrity Impact: Complete
  • Availability Impact: Complete
Affected Products


Infoscience
  • ELC Analytics version 3.0.0 and earlier
  • Logstorage version 8.0.0 and earlier

Impact

When the FTP upload function is enabled and there is a flaw of input value handling in the log processing function "ScriptHandler", crafted log may be uploaded via FTP and an arbitrary OS command may be executed on the server where the products are running.
Solution

[Update the Software]
Update to the latest version according to the information provided by the developer.

[Apply the Workaround]
Applying the following workaround may mitigate the impact of this vulnerability.

*Set the file name patterns of which ScriptHandler processes not to be executed by the file names that include the comma.

For more information, refer to the information provided by the developer.
Vendor Information

Infoscience
CWE (What is CWE?)

  1. OS Command Injection(CWE-78) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2020-5626
References

  1. JVN : JVN#41853173
Revision History

  • [2021/01/27]
      Web page was published