[Japanese]

JVNDB-2020-000055

Apache Struts 2 vulnerable to denial-of-service (DoS)

Overview

Apache Struts 2 provided by The Apache Software Foundation contains a denial-of-service (DoS) vulnerability (CWE-400).

Takeshi Terada of Mitsui Bussan Secure Directions, Inc. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

CVSS V3 Severity:
Base Metrics 5.9 (Medium) [IPA Score]
  • Attack Vector: Network
  • Attack Complexity: High
  • Privileges Required: None
  • User Interaction: None
  • Scope: Unchanged
  • Confidentiality Impact: None
  • Integrity Impact: None
  • Availability Impact: High
CVSS V2 Severity:
Base Metrics 4.3 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: None
  • Integrity Impact: None
  • Availability Impact: Partial
Affected Products


Apache Software Foundation
  • Apache Struts 2.0.0 to 2.5.20

Impact

An attacker may be able to cause a denial-of-service (DoS).
Solution

[Update the Software]
Update to the latest version according to the information provided by the developer

[Apply a Workaround]
Apply the following workaround to mitigate the impact of this vulnerability:

Add java.io. and java.nio. to the value attribute of the struts.excludedPackageNames constant in struts-default.xml

However, it is recommended by the developer to update the software.
Vendor Information

Apache Software Foundation
CWE (What is CWE?)

  1. No Mapping(CWE-Other) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2019-0233
References

  1. JVN : JVN#50890770
Revision History

  • [2020/08/25]
      Web page was published