EC-CUBE plugin "Amazon Pay Plugin 2.12,2.13" vulnerable to cross-site scripting


EC-CUBE plugin "Amazon Pay Plugin 2.12,2.13" provided by IPLOGIC CO.,LTD. contains a cross-site scripting vulnerability (CWE-79).

Gen Sato of Mitsui Bussan Secure Directions, Inc. reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

CVSS V3 Severity:
Base Metrics 6.1 (Medium) [IPA Score]
  • Attack Vector: Network
  • Attack Complexity: Low
  • Privileges Required: None
  • User Interaction: Required
  • Scope: Changed
  • Confidentiality Impact: Low
  • Integrity Impact: Low
  • Availability Impact: None
CVSS V2 Severity:
Base Metrics 2.6 (Low) [IPA Score]
  • Access Vector: Network
  • Access Complexity: High
  • Authentication: None
  • Confidentiality Impact: None
  • Integrity Impact: Partial
  • Availability Impact: None
Affected Products

  • EC-CUBE plugin "Amazon Pay Plugin 2.12,2.13" version 2.4.2 and earlier


An arbitrary script may be executed on the web browser of the user who logs in to the product with the administrative privilege.

[Update the Plugin]
Update to the latest version according to the information provided by the developer.
Vendor Information

CWE (What is CWE?)

  1. Cross-site Scripting(CWE-79) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2019-6003

  1. JVN : JVN#29343839
  2. National Vulnerability Database (NVD) : CVE-2019-6003
Revision History

  • [2019/08/07]
      Web page was published
  • [2019/10/08]
      References : Content was added