[Japanese]

JVNDB-2019-000022

GNU Wget vulnerable to buffer overflow

Overview

GNU Wget contains a buffer overflow vulnerability (CWE-119).

Kusano Kazuhiko reported this vulnerability to IPA.
JPCERT/CC coordinated with the developer under Information Security Early Warning Partnership.
CVSS Severity (What is CVSS?)

CVSS V3 Severity:
Base Metrics 8.8 (High) [IPA Score]
  • Attack Vector: Network
  • Attack Complexity: Low
  • Privileges Required: None
  • User Interaction: Required
  • Scope: Unchanged
  • Confidentiality Impact: High
  • Integrity Impact: High
  • Availability Impact: High
CVSS V2 Severity:
Base Metrics 6.8 (Medium) [IPA Score]
  • Access Vector: Network
  • Access Complexity: Medium
  • Authentication: None
  • Confidentiality Impact: Partial
  • Integrity Impact: Partial
  • Availability Impact: Partial
Affected Products


GNU Project
  • GNU Wget 1.20.1 and earlier

Impact

An attacker may be able to cause a denial-of-service (DoS) or may execute an arbitrary code.
Solution

[Apply the update]
Update GNU Wget according to the information provided by the developer.
Vendor Information

GNU Project
CWE (What is CWE?)

  1. Buffer Errors(CWE-119) [IPA Evaluation]
CVE (What is CVE?)

  1. CVE-2019-5953
References

  1. JVN : JVN#25261088
Revision History

  • [2019/04/03]
      Web page was published