【活用ガイド】

[English]

JVNDB-2017-000237

BOOK☆WALKER for Windows/Mac における複数の脆弱性

概要

株式会社ブックウォーカーが提供する BOOK☆WALKER for Windows/Mac は電子書籍を閲覧するためのアプリケーションです。BOOK☆WALKER for Windows のインストーラには、同一ディレクトリに存在する特定の DLL を読み込んでしまう脆弱性が存在します。また、BOOK☆WALKER for windows/Mac には、細工されたファイルの読み込みによる情報漏えいの脆弱性が存在します。
・BOOK☆WALKER for Windows のインストーラと同一ディレクトリに存在する特定の DLL の読み込み (CWE-427) - CVE-2017-10887
・細工されたファイルの読み込みによる情報漏えい (CWE-200) - CVE-2017-10888

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: NTTコミュニケーションズ株式会社 東内裕二 氏
CVSS による深刻度 (CVSS とは?)

基本値: 7.1 (危険) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし

[参考] CVSS v3 による深刻度
基本値: 5.5 (警告) [IPA値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし
※上記は、CVE-2017-10888の評価になります。

基本値: 6.8 (危険) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

[参考] CVSS v3 による深刻度
基本値: 7.8 (重要) [IPA値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
※上記は、CVE-2017-10887の評価になります。
影響を受けるシステム


株式会社ブックウォーカー
  • BOOK☆WALKER for Windows Ver.1.2.9 およびそれ以前 (CVE-2017-10887, CVE-2017-10888)
  • BOOK☆WALKER for Mac Ver.1.2.5 およびそれ以前 (CVE-2017-10888)

想定される影響

想定される影響は各脆弱性により異なりますが、次のような影響を受ける可能性があります。
・インストーラを実行している権限で、任意のコードを実行される - CVE-2017-10887
・任意のローカルファイルを読み込まれ、情報が漏えいする - CVE-2017-10888
対策

CVE-2017-10887 への対策:
[最新のインストーラを使用する]
BOOK☆WALKER for Windows を新規にインストールする場合は、開発者が提供する情報をもとに、最新のインストーラを使用してください。

CVE-2017-10888 への対策:
[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

株式会社ブックウォーカー
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [IPA評価]
  2. 情報漏えい(CWE-200) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2017-10887
  2. CVE-2017-10888
参考情報

  1. JVN : JVN#18420340
  2. JVN : JVNTA#91240916
更新履歴

[2017年11月14日]
    掲載