【活用ガイド】

[English]

JVNDB-2017-000083

Windows 版 公的個人認証サービス 利用者クライアントソフトのインストーラにおける DLL 読み込みに関する脆弱性

概要

地方公共団体情報システム機構 (J-LIS) が提供する Windows 版 公的個人認証サービス 利用者クライアントソフトのインストーラには、DLL を読み込む際の検索パスに関する処理に不備があり、意図しない DLL を読み込んでしまう脆弱性が存在します。

なお、本脆弱性は JVN#91002412 とは異なる問題です。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 合同会社セキュリティ・プロフェッショナルズ・ネットワーク 吉田 英二(Eiji James Yoshida) 氏、三井物産セキュアディレクション株式会社 吉川 孝志 氏

CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

[参考] CVSS v3 による深刻度
基本値: 7.8 (重要) [IPA値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
影響を受けるシステム

2017年4月27日以前に公開されていた、次のバージョンのインストーラが、本脆弱性の影響を受ける可能性があります。

地方公共団体情報システム機構
  • 公的個人認証サービス 利用者クライアントソフト Ver3.1(Windows7以降対応版)およびそれ以前の Ver3 系
  • 公的個人認証サービス 利用者クライアントソフト (Vista対応版)
  • 公的個人認証サービス 利用者クライアントソフト Ver2.6 およびそれ以前

想定される影響

インストーラを実行している権限で、任意のコードを実行される可能性があります。
対策

[最新のインストーラを使用する]
開発者が提供する情報をもとに、最新のインストーラを使用してください。
本脆弱性の影響を受けるのはインストーラの起動時のみのため、既存のユーザは Windows 版 公的個人認証サービス 利用者クライアントソフトをアップデートする必要はありません。

なお、公的個人認証サービス 利用者クライアントソフト Ver2.6 以前および Vista対応版のインストーラの配布は終了しています。
ベンダ情報

地方公共団体情報システム機構
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2017-2157
参考情報

  1. JVN : JVN#39605485
更新履歴

[2017年05月09日]
  掲載