【活用ガイド】

JVNDB-2016-006637

Memcached の process_bin_append_prepend 関数における整数オーバーフローの脆弱性

概要

Memcached の process_bin_append_prepend 関数には、整数オーバーフローの脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 7.5 (危険) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

[参考] CVSS v3 による深刻度
基本値: 9.8 (緊急) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
影響を受けるシステム


Memcached
  • Memcached 1.4.31

想定される影響

Memcached のバイナリプロトコルの複数のコマンドを処理されることで、ヒープオーバーフローを引き起こされ、その結果、リモートでコードを実行される可能性があります。
対策

ベンダ情報および参考情報を参照して適切な対策を実施してください。
ベンダ情報

Memcached シスコシステムズ レッドハット
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 整数オーバーフローまたはラップアラウンド(CWE-190) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-8704
参考情報

  1. National Vulnerability Database (NVD) : CVE-2016-8704
更新履歴

[2017年01月18日]
  掲載