【活用ガイド】

JVNDB-2016-001812

DameWare Mini Remote Control にスタックバッファオーバーフローの脆弱性

概要

SolarWinds が提供する DameWare Mini Remote Control には、スタックベースのバッファオーバーフローの脆弱性が存在します。

スタックベースのバッファオーバーフロー (CWE-121) - CVE-2016-2345
DameWare Mini Remote Control は、ヘルプデスクのリモートデスクトップ接続などによるサポート作業を補助するソフトウェアです。発見者によると、DameWare Mini Remote Control の dwrcs.exe には、スタックベースのバッファオーバーフローの脆弱性が存在するとのことです。遠隔の攻撃者は細工したデータを送りつけることで、機密情報を取得したり、任意のコードを実行したりすることが可能です。発見者はさらに詳しい情報を含むアドバイザリを公開しています。

CWE-121: Stack-based Buffer Overflow
http://cwe.mitre.org/data/definitions/121.html

アドバイザリ
https://www.securifera.com/advisories/CVE-2016-2345/

CERT/CC ではこの情報が正しいかどうか、開発者の見解を得られていません。
CVSS による深刻度 (CVSS とは?)

基本値: 10.0 (危険) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 全面的
  • 完全性への影響(I): 全面的
  • 可用性への影響(A): 全面的

[参考] CVSS v3 による深刻度
基本値: 9.8 (緊急) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
影響を受けるシステム


SolarWinds
  • DameWare Mini Remote Control version 12.0.3 より前のバージョン

想定される影響

遠隔の第三者によって、機密情報を取得されたり、SYSTEM 権限で任意のコードを実行されたりする可能性があります。
対策

[アップデートする]
開発者は、この問題を修正したバージョン 12.0.3 をリリースしています。
対象製品のユーザは可能な限り早く最新版へアップデートしてください。
ベンダ情報

SolarWinds
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [IPA評価]
  2. バッファエラー(CWE-119) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-2345
参考情報

  1. JVN : JVNVU#95244076
  2. National Vulnerability Database (NVD) : CVE-2016-2345
  3. US-CERT Vulnerability Note : VU#897144
  4. 関連文書 : CVE-2016-2345 - Securifera
更新履歴

[2016年03月22日]
  掲載
[2016年05月30日]
  CVSS による深刻度:内容を更新
  影響を受けるシステム:内容を更新
  対策:内容を更新