【活用ガイド】

JVNDB-2016-001795

Android の Conscrypt の TrustManagerImpl.java の TrustManagerImpl クラスにおけるサーバになりすまされる脆弱性

概要

Android の Conscrypt の TrustManagerImpl.java の TrustManagerImpl クラスのキャッシュ機能は、中間 CA と信頼できるルート CA との区別を誤って処理するため、サーバになりすまされる脆弱性が存在します。

ベンダは、本脆弱性を Bug 26232830 として公開しています。

補足情報 : CWE による脆弱性タイプは、CWE-254: Security Features (セキュリティ機能)、および CWE-345: Insufficient Verification of Data Authenticity (データの信頼性についての不十分な検証) と識別されています。
http://cwe.mitre.org/data/definitions/254.html
http://cwe.mitre.org/data/definitions/345.html
CVSS による深刻度 (CVSS とは?)

基本値: 4.3 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


Google
  • Android 4.4.4 未満の 4.x
  • Android 5.1.1 LMY49H 未満の 5.x
  • Android 2016-03-01 より前の 6.x

想定される影響

中間者攻撃 (man-in-the-middle attack) により、中間 CA へのアクセスを利用され、証明書を発行されることで、サーバになりすまされる可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Google
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-0818
参考情報

  1. National Vulnerability Database (NVD) : CVE-2016-0818
更新履歴

[2016年03月22日]
  掲載