【活用ガイド】

JVNDB-2016-001613

OpenSSL の crypto/dsa/dsa_ameth.c の dsa_priv_decode 関数におけるメモリ二重解放の脆弱性

概要

OpenSSL の crypto/dsa/dsa_ameth.c の dsa_priv_decode 関数には、メモリ二重解放の脆弱性が存在します。

補足情報 : CWE による脆弱性タイプは、CWE-415: Double Free (二重解放) と識別されています。
http://cwe.mitre.org/data/definitions/415.html
CVSS による深刻度 (CVSS とは?)

基本値: 10.0 (危険) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 全面的
  • 完全性への影響(I): 全面的
  • 可用性への影響(A): 全面的

影響を受けるシステム


OpenSSL Project
  • OpenSSL 1.0.1s 未満の 1.0.1
  • OpenSSL 1.0.2g 未満の 1.0.2

想定される影響

第三者により、不正な形式の DSA 秘密鍵を介して、サービス運用妨害 (メモリ破損) 状態にされるなど、不特定の影響を受ける可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

OpenSSL Project オラクル
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-0705
参考情報

  1. National Vulnerability Database (NVD) : CVE-2016-0705
更新履歴

[2016年03月08日]
  掲載
[2016年05月23日]
  ベンダ情報:オラクル (Oracle Critical Patch Update CVSS V2 Risk Matrices - April 2016) を追加
  ベンダ情報:オラクル (Oracle Critical Patch Update Advisory - April 2016) を追加
  ベンダ情報:オラクル (Text Form of Oracle Critical Patch Update - April 2016 Risk Matrices) を追加
  ベンダ情報:オラクル (April 2016 Critical Patch Update Released) を追加