【活用ガイド】

JVNDB-2016-001599

Android の Debuggerd の elf_utils.cpp の get_build_id 関数における権限を取得される脆弱性

概要

Android の Debuggerd の elf_utils.cpp の get_build_id 関数には、権限を取得される脆弱性が存在します。

ベンダは、本脆弱性を Bug 25187394 として公開しています。
CVSS による深刻度 (CVSS とは?)

基本値: 7.2 (危険) [NVD値]
  • 攻撃元区分: ローカル
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 全面的
  • 完全性への影響(I): 全面的
  • 可用性への影響(A): 全面的

影響を受けるシステム


Google
  • Android 2016-02-01 までの 6.x

想定される影響

攻撃者により、ELF Note の Desc Size 要素を誤って処理する巧妙に細工されたアプリケーションを介して、権限を取得される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Google
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 認可・権限・アクセス制御(CWE-264) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-0807
参考情報

  1. National Vulnerability Database (NVD) : CVE-2016-0807
更新履歴

[2016年03月07日]
  掲載
[2016年03月16日]
  CVSS による深刻度:内容を更新
  CWE による脆弱性タイプ一覧:CWE-ID を追加