【活用ガイド】

JVNDB-2016-001567

phpMyAdmin の libraries/Config.class.php の checkHTTP 関数におけるサーバになりすまされる脆弱性

概要

phpMyAdmin の libraries/Config.class.php の checkHTTP 関数は、api.github.com SSL サーバからの X.509 証明書を検証しないため、サーバになりすまされ、重要な情報を取得される脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 5.8 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


The phpMyAdmin Project
  • phpMyAdmin 4.5.5.1 未満の 4.5.x

想定される影響

中間者攻撃 (man-in-the-middle attack) により、巧妙に細工された証明書を介して、サーバになりすまされ、重要な情報を取得される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

The phpMyAdmin Project
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 不適切な入力確認(CWE-20) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-2562
参考情報

  1. National Vulnerability Database (NVD) : CVE-2016-2562
更新履歴

[2016年03月04日]
  掲載