【活用ガイド】

JVNDB-2016-001565

phpMyAdmin におけるクロスサイトスクリプティングの脆弱性

概要

phpMyAdmin には、クロスサイトスクリプティングの脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 4.3 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


The phpMyAdmin Project
  • phpMyAdmin 4.0.10.15 未満の 4.0.x
  • phpMyAdmin 4.4.15.5 未満の 4.4.x
  • phpMyAdmin 4.5.5.1 未満の 4.5.x

想定される影響

第三者により、以下を介して、任意の Web スクリプトまたは HTML を挿入される可能性があります。

(1) libraries/Config.class.php に関連する巧妙に細工された Host HTTP ヘッダ
(2) file_echo.php に関連する巧妙に細工された JSON データ
(3) js/functions.js に関連する巧妙に細工された SQL クエリ
(4) ユーザアカウントページの libraries/server_privileges.lib.php の initial パラメータ
(5) zoom search ページの libraries/controllers/TableSearchController.class.php の it パラメータ
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

The phpMyAdmin Project
CWEによる脆弱性タイプ一覧  CWEとは?

  1. クロスサイトスクリプティング(CWE-79) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-2560
参考情報

  1. National Vulnerability Database (NVD) : CVE-2016-2560
更新履歴

[2016年03月04日]
  掲載