【活用ガイド】

JVNDB-2016-001555

Moodle の core_enrol_get_course_enrolment_methods および enrol_self_get_instance_info Web サービスにおける重要な情報を取得される脆弱性

概要

Moodle の (1) core_enrol_get_course_enrolment_methods、および (2) enrol_self_get_instance_info Web サービスは、moodle/course:viewhiddencourses ケイパビリティを考慮しないため、重要な情報を取得される脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 4.0 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし

影響を受けるシステム


Moodle
  • Moodle 2.6.11 まで
  • Moodle 2.7.12 未満の 2.7.x
  • Moodle 2.8.10 未満の 2.8.x
  • Moodle 2.9.4 未満の 2.9.x
  • Moodle 3.0.2 未満の 3.0.x

想定される影響

リモート認証されたユーザにより、web-service リクエストを介して、重要な情報を取得される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Moodle
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 情報漏えい(CWE-200) [NVD評価]
  2. 認可・権限・アクセス制御(CWE-264) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-0724
参考情報

  1. National Vulnerability Database (NVD) : CVE-2016-0724
更新履歴

[2016年03月03日]
  掲載