【活用ガイド】

JVNDB-2016-001542

Wireshark の DNP3 ディセクタの epan/dissectors/packet-dnp.c におけるサービス運用妨害 (DoS) の脆弱性

概要

Wireshark の DNP3 ディセクタ (解析機能) の epan/dissectors/packet-dnp.c 内の dnp3_al_process_object 関数には、サービス運用妨害 (無限ループ) 状態にされる脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 7.1 (危険) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): なし
  • 可用性への影響(A): 全面的

影響を受けるシステム


Wireshark
  • Wireshark 1.12.10 未満の 1.12.x
  • Wireshark 2.0.2 未満の 2.0.x

想定される影響

第三者により、巧妙に細工されたパケットを介して、サービス運用妨害 (無限ループ) 状態にされる可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Wireshark
CWEによる脆弱性タイプ一覧  CWEとは?

  1. リソース管理の問題(CWE-399) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-2523
参考情報

  1. National Vulnerability Database (NVD) : CVE-2016-2523
更新履歴

[2016年03月02日]
  掲載