【活用ガイド】

JVNDB-2016-001522

JanRain PHP OpenID ライブラリ の examples/consumer/common.php における任意のユーザの認証をハイジャックされる脆弱性

概要

JanRain PHP OpenID ライブラリ (別名 php-openid) の examples/consumer/common.php は、SERVER スーパーグローバルの配列の SERVER_NAME 要素に対する openid.realm パラメータを適切にチェックしないため、任意のユーザの認証をハイジャックされる脆弱性が存在します。

補足情報 : CWE による脆弱性タイプは、CWE-284: Improper Access Control (不適切なアクセス制御) と識別されています。
http://cwe.mitre.org/data/definitions/284.html
CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


JanRain
  • PHP OpenID

想定される影響

第三者により、巧妙に細工された HTTP Host ヘッダに関する問題によって、任意のユーザの認証をハイジャックされる可能性があります。
対策

ベンダ情報および参考情報を参照して適切な対策を実施してください。
ベンダ情報

JanRain
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-2049
参考情報

  1. National Vulnerability Database (NVD) : CVE-2016-2049
  2. 関連文書 : CVE Request: Host based account hijack attack on php-openid
  3. 関連文書 : Re: CVE Request: Host based account hijack attack on php-openid
更新履歴

[2016年02月29日]
  掲載
[2016年03月07日]
  概要:内容を更新
  CVSS による深刻度:内容を更新
  CWE による脆弱性タイプ一覧:CWE-ID を追加