【活用ガイド】

[English]

JVNDB-2016-000159

H2O における書式指定文字列に関する脆弱性

概要

H2O は、オープンソースのウェブサーバソフトウェアです。H2O のエラーログ出力処理には、書式指定文字列に関する脆弱性 (CWE-134) が存在します。

この脆弱性情報は、製品利用者への周知を目的に、開発者が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
CVSS による深刻度 (CVSS とは?)

基本値: 4.3 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): なし
  • 完全性への影響(I): なし
  • 可用性への影響(A): 部分的

[参考] CVSS v3 による深刻度
基本値: 3.7 (注意) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): なし
  • 完全性への影響(I): なし
  • 可用性への影響(A): 低
影響を受けるシステム


奥 一穂
  • H2O version 2.0.3 およびそれ以前
  • H2O version 2.1.0-beta2 およびそれ以前

想定される影響

遠隔の第三者によって、サービス運用妨害 (DoS) 攻撃を受ける可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

奥 一穂
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 書式文字列の問題(CWE-134) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-4864
参考情報

  1. JVN : JVN#94779084
  2. National Vulnerability Database (NVD) : CVE-2016-4864
更新履歴

[2016年09月15日]
  掲載
[2017年11月27日]
  参考情報:National Vulnerability Database (NVD) (CVE-2016-4864) を追加