【活用ガイド】

[English]

JVNDB-2016-000001

DXライブラリにおけるバッファオーバーフローの脆弱性

概要

DXライブラリは、Windows ソフトウエア開発用のオープンソースのライブラリです。DXライブラリには、内部関数 CL_vsprintf() の処理に起因するバッファオーバーフローの脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 北川 智也 氏

CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

[参考] CVSS v3 による深刻度
基本値: 8.1 (重要) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃に必要な特権レベル: 不要
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 高
  • 完全性への影響(I): 高
  • 可用性への影響(A): 高
影響を受けるシステム


山田巧
  • DXライブラリ VisualC++用 Ver3.15e およびそれ以前
  • DXライブラリ BorlandC++用 Ver3.15e およびそれ以前
  • DXライブラリ Gnu C++用 Ver3.15e およびそれ以前
  • DXライブラリ VisualC#用 Ver3.15e およびそれ以前

想定される影響

DXライブラリを使用して作成されたアプリケーションが、細工された文字列を処理することで、アプリケーションの権限で任意のコードを実行される可能性があります。
対策

[リビルドし、アップデートする]
DXライブラリを使用したアプリケーションの開発者は、対策済みのDXライブラリを使用してリビルドし、アプリケーションをアップデートしてください。
ベンダ情報

山田巧
CWEによる脆弱性タイプ一覧  CWEとは?

  1. バッファエラー(CWE-119) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2016-1131
参考情報

  1. JVN : JVN#49476817
  2. National Vulnerability Database (NVD) : CVE-2016-1131
  3. IPA 重要なセキュリティ情報 : 「DXライブラリ」におけるバッファオーバーフローの脆弱性対策について(JVN#49476817)
更新履歴

[2016年01月05日]
  掲載
[2016年01月13日]
  参考情報:National Vulnerability Database (NVD) (CVE-2016-1131) を追加
[2016年06月08日]
  ベンダ情報:URLを更新