【活用ガイド】

JVNDB-2015-006002

Apache Cordova Android におけるブリッジハイジャック攻撃を実行される脆弱性

概要

Apache Cordova Android は、BridgeSecret データ用にランダム値を適切に生成しないため、ブリッジハイジャック攻撃を実行される脆弱性が存在します。

補足情報 : CWE による脆弱性タイプは、CWE-330: Use of Insufficiently Random Values (不十分なランダム値の使用) と識別されています。
http://cwe.mitre.org/data/definitions/330.html
CVSS による深刻度 (CVSS とは?)

基本値: 5.0 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): なし
  • 可用性への影響(A): なし

影響を受けるシステム


Apache Software Foundation
  • Apache Cordova Android 3.7.0 未満

想定される影響

攻撃者により、ランダム値を予測されることで、ブリッジハイジャック攻撃を実行される可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

Apache Software Foundation
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2015-8320
参考情報

  1. National Vulnerability Database (NVD) : CVE-2015-8320
更新履歴

[2015年11月24日]
  掲載