【活用ガイド】

JVNDB-2015-005945

FFmpeg の libavcodec/faxcompr.c の decode_uncompressed 関数におけるサービス運用妨害 (DoS) の脆弱性

概要

FFmpeg の libavcodec/faxcompr.c の decode_uncompressed 関数は、非圧縮で実行されているかどうかを検証しないため、サービス運用妨害 (配列の領域外へのアクセス) 状態にされるなど、不特定の影響を受ける脆弱性が存在します。
CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [NVD値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム


FFmpeg
  • FFmpeg 2.8.2 未満

想定される影響

第三者により、 巧妙に細工された CCITT FAX データを介して、サービス運用妨害 (配列の領域外へのアクセス) 状態にされるなど、不特定の影響を受ける可能性があります。
対策

ベンダより正式な対策が公開されています。ベンダ情報を参照して適切な対策を実施してください。
ベンダ情報

FFmpeg
CWEによる脆弱性タイプ一覧  CWEとは?

  1. 不適切な入力確認(CWE-20) [NVD評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2015-8218
参考情報

  1. National Vulnerability Database (NVD) : CVE-2015-8218
更新履歴

[2015年11月18日]
  掲載