【活用ガイド】

[English]

JVNDB-2015-000200

WordPress 用プラグイン Welcart における SQL インジェクションの脆弱性

概要

コルネ株式会社が提供する Welcart は、ショッピングサイトを構築するための WordPress 用プラグインです。Welcart には、admin.php における search[column] および switch パラメータの処理に起因する SQL インジェクション (CWE-89) の脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 馬場 将次 氏

CVSS による深刻度 (CVSS とは?)

基本値: 6.5 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

[参考] CVSS v3 による深刻度
基本値: 6.3 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 低
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 低
  • 完全性への影響(I): 低
  • 可用性への影響(A): 低
影響を受けるシステム


コルネ株式会社
  • Welcart V1.5.2 およびそれ以前

想定される影響

第三者によって、データベース内の情報を取得されたり、改ざんされたりする可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

コルネ株式会社
CWEによる脆弱性タイプ一覧  CWEとは?

  1. SQLインジェクション(CWE-89) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2015-7791
参考情報

  1. JVN : JVN#43344629
  2. National Vulnerability Database (NVD) : CVE-2015-7791
更新履歴

[2015年12月17日]
  掲載
[2016年01月07日]
  参考情報:National Vulnerability Database (NVD) (CVE-2015-7791) を追加