【活用ガイド】

[English]

JVNDB-2015-000190

EC-CUBE 用プラグイン「管理画面表示制御プラグイン」における SQL インジェクションの脆弱性

概要

ボクブロック株式会社が提供する EC-CUBE 用プラグイン「管理画面表示制御プラグイン」には、SQL インジェクション (CWE-89) の脆弱性が存在します。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 株式会社トレードワークス セキュリティ事業部 佐藤 元 氏

CVSS による深刻度 (CVSS とは?)

基本値: 5.5 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃前の認証要否: 単一
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): なし
  • 可用性への影響(A): 部分的

[参考] CVSS v3 による深刻度
基本値: 5.4 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 低
  • 攻撃に必要な特権レベル: 低
  • 利用者の関与: 不要
  • 影響の想定範囲: 変更なし
  • 機密性への影響(C): 低
  • 完全性への影響(I): なし
  • 可用性への影響(A): 低
影響を受けるシステム


ボクブロック株式会社
  • 管理画面表示制御プラグイン (2.13系) Ver1.0 およびそれ以前
  • 管理画面表示制御プラグイン (2.12系) Ver2.0 およびそれ以前

想定される影響

当該製品にログイン済みのユーザによって、SQL 文を実行される可能性があります。
開発者によると、本脆弱性によってデータベースの機密性や可用性に影響が及ぶものの、データベース内の情報を改ざんされることはないとのことです。
対策

[管理画面表示制御プラグインを使用しない]
管理画面表示制御プラグインの配布は既に終了しています。管理画面表示制御プラグインの使用を停止してください。
ベンダ情報

ボクブロック株式会社
CWEによる脆弱性タイプ一覧  CWEとは?

  1. SQLインジェクション(CWE-89) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2015-7784
参考情報

  1. JVN : JVN#55545372
  2. National Vulnerability Database (NVD) : CVE-2015-7784
更新履歴

[2015年12月03日]
  掲載
[2016年01月12日]
  参考情報:National Vulnerability Database (NVD) (CVE-2015-7784) を追加
[2016年07月07日]
  CVSS による深刻度:内容を更新
  想定される影響:内容を更新
  対策:内容を更新
  ベンダ情報:ボクブロック株式会社 (トップページ) を追加