【活用ガイド】

[English]

JVNDB-2015-000159

iOS 版 Party Track SDK におけるサーバ証明書の検証不備の脆弱性

概要

株式会社アドウェイズが提供する iOS 版 Party Track SDK が組み込まれた iOS アプリには、HTTPS を利用した暗号通信において、サーバ証明書を適切に検証しない脆弱性が存在します。
開発者によると、SDK が行う通信以外にも、NSURLConnection を使って行うアプリ内の通信全般がサーバ証明書を検証しない状態になるとのことです。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: LINE株式会社 ma.la 氏

CVSS による深刻度 (CVSS とは?)

基本値: 4.0 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 高
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): なし

影響を受けるシステム


株式会社アドウェイズ
  • Party Track SDK 1.6.6 より前のバージョン

上記製品を組み込んだアプリケーションが、本脆弱性の影響を受けます。
想定される影響

通信経路上の第三者に暗号通信の内容を盗聴される、あるいは通信内容を改ざんされるなど、中間者攻撃 (man-in-the-middle attack) の被害を受ける可能性があります。
対策

[SDK をアップデートし、アプリケーションをリビルドする]
iOS 版 Party Track SDK を組み込んだアプリケーションの開発者は、株式会社アドウェイズが提供する情報をもとに対策済みの Party Track SDK にアップデートし、アプリケーションをリビルドしてください。
ベンダ情報

CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2015-5655
参考情報

  1. JVN : JVN#48211537
  2. National Vulnerability Database (NVD) : CVE-2015-5655
更新履歴

[2015年10月14日]
  掲載
[2015年10月22日]
  概要:内容を更新
[2015年11月11日]
  参考情報:National Vulnerability Database (NVD) (CVE-2015-5655) を追加