【活用ガイド】

[English]

JVNDB-2015-000118

Apache Tapestry における信頼できないデータをデシリアライズする脆弱性

概要

Apache Tapestry には、信頼できないデータをデシリアライズする脆弱性が存在します。

Apache Software Foundation が提供する Apache Tapestry は、ウェブアプリケーションを作成するためのフレームワークです。Apache Tapestry は、クライアント側でシリアライズされたデータをエンコードした上でサーバに送信し、サーバ側で受け取ったデータをデシリアライズするインターフェースを備えています。
このデータのシリアライズ / デシリアライズ処理には、データの正当性を確認する仕組みが存在しません。そのため、シリアライズされたデータが改ざんされたり細工されたりした場合、サーバ側はデータを検証することなくデシリアライズします (CWE-502)。

この脆弱性情報は、情報セキュリティ早期警戒パートナーシップに基づき下記の方が IPA に報告し、JPCERT/CC が開発者との調整を行いました。
報告者: 三井物産セキュアディレクション株式会社 寺田 健 氏

CVSS による深刻度 (CVSS とは?)

基本値: 6.8 (警告) [IPA値]
  • 攻撃元区分: ネットワーク
  • 攻撃条件の複雑さ: 中
  • 攻撃前の認証要否: 不要
  • 機密性への影響(C): 部分的
  • 完全性への影響(I): 部分的
  • 可用性への影響(A): 部分的

影響を受けるシステム

次のバージョンの Apache Tapestry を使⽤して作成されたウェブアプリケーションが本脆弱性の影響を受けます。

Apache Software Foundation
  • Apache Tapestry 5.0.x (全バージョン)
  • Apache Tapestry 5.1.x (全バージョン)
  • Apache Tapestry 5.2.x (全バージョン)
  • Apache Tapestry 5.3 から 5.3.5 まで

なお、開発者によると、サポート対象外である Apache Tapestry 3.x および 4.x も、本脆弱性の影響を受ける可能性があるとのことです。
想定される影響

サーバが、細工されたデータをデシリアライズすることで、任意のファイルが書き込まれたり、任意のコードが実行されたりする可能性があります。
対策

[アップデートする]
開発者が提供する情報をもとに、最新版へアップデートしてください。
ベンダ情報

Apache Software Foundation
CWEによる脆弱性タイプ一覧  CWEとは?

  1. その他(CWE-Other) [IPA評価]
共通脆弱性識別子(CVE)  CVEとは?

  1. CVE-2014-1972
参考情報

  1. JVN : JVN#17611367
  2. National Vulnerability Database (NVD) : CVE-2014-1972
  3. JPCERT : Oracle Java 標準ライブラリ AtomicReferenceArray クラスにおけるデシリアライズに関する脆弱性
  4. JPCERT : SER02-J. センシティブなオブジェクトは信頼境界を越えて送信する前に署名し暗号化する
更新履歴

[2015年08月20日]
  掲載
[2015年08月26日]
  参考情報:National Vulnerability Database (NVD) (CVE-2014-1972) を追加